Date: prev next · Thread: first prev next last
2010 Archives by date, by thread · List index

On 16/10/10 17:37, Kertesz Laszlo wrote:
On Sat, 16 Oct 2010 19:25:46 +0300, AG <> wrote:

On 16/10/10 16:24, AG wrote:
On 16/10/10 12:36, Kertesz Laszlo wrote:

You have to completely remove the installed LibreOffice version (all lobasis* or libobasis* packages too)- there are some library differences between beta 1 and 2. I had the same issue and i solved it like that.

BTW, here is a LibreOffice Debian repo that seems to be up to date: Have a nice day,

Kertesz Laszlo

On Sat, 16 Oct 2010 14:21:45 +0300, AG <> wrote:

Hi all

I dropped this into the thread on the beta 2 release, but that was the wrong place and it subsequently got lost. So, to give it its own thread just in case others need it in the future.

For my Debian system, I found and once I downloaded the relevant deb tarball I ran into some difficulties installing it. I unpacked the tarball and ran, as sudo, sh update.

The process kicked up some errors, which concerned the following messages:



(1) was running update the appropriate installation/ updating method to install beta 2 and if not, what is? and/ or (2) have these issues been reported by others using the debian packages?

FWIW, I'm running an up-to-date Debian testing on a stand alone machine. It has OOo and LibO beta 1 installed (& these actually seem to co-exist quite happily).

Thank you for any ideas on how to install beta 2.


Thanks for the suggestion - this I did, and still received the following two errors:

Errors were encountered while processing:

If the core1 doesn't install, it seems like the rest won't either!

I have now downloaded the package as Kertesz suggested and run sh update.

Additional error messages are now that the application could not be started because "iso resource could not be loaded by SfxApplicator".


I'd appreciate any help on this please.



I dont know about that error, i never used the update script.

I just dpkg-ed all debs from the DEBS folder and the DEBS/desktop-integration/ with the command (path is the path to the unpacked .debs):

sudo dpkg -i /path/*.deb

Now i installed beta1 from the tar.gz from the site and beta2 from the repository i mentioned. There were the library conflicts as AG observed. I purged all libreoffice related stuff and i installed beta2 and all is well.


Thanks for the more detailed instructions which I have now successfully followed.

The beta 2 now launches as expected without errors.

Thank you again!!

On a general note, I wonder if it would be worthwhile for the packagers of LibO to (a) include installation instruction documentation somewhere on their site where these can be easil;y found and used, and (b) to develop a script that will actually perform the installation. While I may not be the sharpest crayon in the pack, I obviously have had a fair bit of problems installing this onto my machine and to be honest going through this degree of hassle may well put some people off from even trying it in the first place.

Once again, Kertesz, my gratitude for your help and patience.

Best wishes


E-mail to for instructions on how to unsubscribe
List archives are available at
All messages you send to this list will be publicly archived and cannot be deleted


Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.