Date: prev next · Thread: first prev next last
2011 Archives by date, by thread · List index

Re: [tdf-discuss] Re: Unable to use SCIM to import CJK languages into LibreOffice on 64-bit Ubuntu 10.10


2011/2/21 NoOp <glgxg@sbcglobal.net>

On 02/20/2011 07:39 AM, M Henri Day wrote:
I recently had occasion to reinstall 64-bit Ubuntu 10.10 (n b, not
because
of a problem in Ubuntu itself, but because I replaced Windows Vista with
Windows 7 on the Windows side of this dual-boot machine and thereafter
failed in my attempts to restore GRUB2) and after doing so, noticed that
no
matter what I tried, I was unable to get SCIM to import CJK languages
into a
Writer text. Same problem, of course, when using OOo ; I'm using the
latest
(Swedish) 3.3 version in both cases. SCIM works fine with other
applications
on Ubuntu, like the gedit text editor or Gmail's compose. In contrast to
the
situation on Ubuntu, I have no problem using the Microsoft IMEs to import
these languages into LO or OOo texts. However, I don't want to be forced
to
run Windows 7 in order to write, e g, a Chinese or Japanese text in a LO
or
OOo document. Is it possible to get SCIM and LO to play nice with each
other
and in that event, does anyone have any suggestions as to how to go about
doing so ?...

Henri


Perhaps try iBus instead?
https://help.ubuntu.com/community/ibus


NoOp, thanks for your suggestion. Alas, I found myself unable to get IBus to
work ; for example, after installing IBus according to the instructions on
the Ubuntu Community page and adding Chinese and Japan, I didn't find «IBus
Preferences» under «System» → «Preferences», nor did «Ctrl + Space» start
IBus in, e g, LibreOffice, despite my having selected «ibus» as my keyboard
input method under «System» → «Administration» → «Language Support». So I'm
still trying to get SCIM to work. The thing that surprised me with respect
to Christian's advice above to set SCIM as my «global default» was that I
thought I had already  done so ; i e, I had edited my profile under /etc by
adding the following :
# SCIM
export XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"
scim -d

I had also ensured that the following lines appeared in /etc/scim/global :
/SupportedUnicodeLocales = sv_SE.utf8,en_US.UTF-8. Previously, these
measures have sufficed to make SCIM work with OOo/LO....

What next ?...

Henri

-- 
Unsubscribe instructions: E-mail to discuss+help@documentfoundation.org
Archive: http://listarchives.documentfoundation.org/www/discuss/
*** All posts to this list are publicly archived for eternity ***

Context


Privacy Policy | Impressum (Legal Info) | Copyright information: Unless otherwise specified, all text and images on this website are licensed under the Creative Commons Attribution-Share Alike 3.0 License. This does not include the source code of LibreOffice, which is licensed under the Mozilla Public License (MPLv2). "LibreOffice" and "The Document Foundation" are registered trademarks of their corresponding registered owners or are in actual use as trademarks in one or more countries. Their respective logos and icons are also subject to international copyright laws. Use thereof is explained in our trademark policy.